IPB

Здравствуйте, гость ( Вход | Регистрация )

ModPlus v11.8.2.0, AutoCAD plugin
Slinger
сообщение 15.09.2020 - 00:32
Сообщение #61


Флудер
Иконка группы

Группа: Модераторы
Пользователь №: 143610
Сообщений: 758
Регистрация: 7.03.2011
Загружено: 0 байт
Скачано: 0 байт
Коэффициент: ---
Спасибо сказали: 1796 раз(а)





ModPlus - это модульное программное обеспечение, являющееся дополнением для программных комплексов автоматизированного проектирования (САПР), таких как AutoCAD, Revit и пр.

ModPlus состоит из нескольких отдельных компонентов:
- Конфигуратор – основа ModPlus. Служит для конфигурации плагинов, настройки меню, выбора привязки вашей версии и пр.
- Модуль автообновлений – специальной разработанный модуль, который мониторит и обновляет компоненты ModPlus в автоматическом режиме. Модуль автообновления также позволяет ставить обновления или недостающие компоненты в оффлайн-режиме (без доступа к сети internet).
- Рабочие библиотеки – библиотеки (*.dll), требуемые для подключения ModPlus к AutoCAD/Revit, а также вспомогательные библиотеки и библиотеки сторонних разработчиков.
- Базы данных - содержат информацию по сортаментам, материалам и т.п. Базы данных сделаны в виде dll-библиотек и используются некоторыми плагинами для AutoCAD.
- База dwg– специальная база файлов в формате *.dwg, используемых плагином База dwg.
- Плагины – непосредственно сами плагины в виде одиночных dll-библиотек.

Такая разбивка позволяет обновлять компоненты ModPlus независимо от остальных компонентов, что в свою очередь приводит к главному плюсу – не нужно ждать обновления всего ModPlus. Например, Вы нашли баг в каком-то плагине и сообщили авторам. И уже завтра Вы и все остальные пользователи сможете получить новую версию плагина с исправленным багом (конечно, это при условии наличия возможностей у разработчиков). Таких возможностей больше нет ни в одном программном обеспечении!

Version 11.8.2.0

» Click to show Spoiler - click again to hide... «
https://nitro.download/view/2AE3F004AF110D5/11.8.2.0_cracked.rar


Сообщение отредактировал Slinger - 7.06.2021 - 15:26
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
4 страниц V  « < 2 3 4  
Начать новую тему
Ответов
Slinger
сообщение 24.03.2021 - 21:34
Сообщение #62


Флудер
Иконка группы

Группа: Модераторы
Пользователь №: 143610
Сообщений: 758
Регистрация: 7.03.2011
Загружено: 0 байт
Скачано: 0 байт
Коэффициент: ---
Спасибо сказали: 1796 раз(а)



Обновлено до 11.7.0.0
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Slinger
сообщение 8.04.2021 - 10:39
Сообщение #63


Флудер
Иконка группы

Группа: Модераторы
Пользователь №: 143610
Сообщений: 758
Регистрация: 7.03.2011
Загружено: 0 байт
Скачано: 0 байт
Коэффициент: ---
Спасибо сказали: 1796 раз(а)



Обновлено до 11.8.0.0
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
arturice
сообщение 4.05.2021 - 18:01
Сообщение #64


Новичок
Иконка группы

Группа: Пользователи
Пользователь №: 91931
Сообщений: 15
Регистрация: 25.06.2008
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 3 раз(а)



Добрый день, если не сложно можете выложить обновленную версию плагина, 29 числа обновились модули, я по ошибке снес старую версию 11.7, 11.8 уже не работает. (((
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Nfors85
сообщение 7.05.2021 - 09:23
Сообщение #65


Из местных
Иконка группы

Группа: Пользователи
Пользователь №: 124536
Сообщений: 52
Регистрация: 1.10.2009
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 13 раз(а)



Цитата(arturice @ 4.05.2021 - 18:01) *
Добрый день, если не сложно можете выложить обновленную версию плагина, 29 числа обновились модули, я по ошибке снес старую версию 11.7, 11.8 уже не работает. (((

на 07.05.2021 последняя версия конфиругатора 11.8. Нечего патчить новее
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
arturice
сообщение 7.05.2021 - 17:57
Сообщение #66


Новичок
Иконка группы

Группа: Пользователи
Пользователь №: 91931
Сообщений: 15
Регистрация: 25.06.2008
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 3 раз(а)



Цитата(Nfors85 @ 7.05.2021 - 09:23) *
Цитата(arturice @ 4.05.2021 - 18:01) *
Добрый день, если не сложно можете выложить обновленную версию плагина, 29 числа обновились модули, я по ошибке снес старую версию 11.7, 11.8 уже не работает. (((

на 07.05.2021 последняя версия конфиругатора 11.8. Нечего патчить новее

Наверное что-то с ревитом, выскакивают ошибки при нажатии на иконки программы.
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Bokko
сообщение 10.05.2021 - 21:46
Сообщение #67


Прохожий
Иконка группы

Группа: Пользователи
Пользователь №: 79610
Сообщений: 35
Регистрация: 22.11.2007
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 23 раз(а)



Установил на Revit 2022. При нажатии на "Армирование колонн" сразу появляется ошибка "Вызов конструктора для типа "mprColumnsReinforcement.Views.ReinforcementDataControl", удовлетворяющего указанным ограничениям привязки, привел к выдаче исключения."
"Источник PresentationFramework. Трассировка стека: " в System.Windows.Markup.XamlReader.RewrapException(Exception e, IXamlLineInfo lineInfo, Uri baseUri)
в System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
в System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
в System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
в mprColumnsReinforcement.Views.MainWindow.InitializeComponent()
в mprColumnsReinforcement.Views.MainWindow..ctor()
в mprColumnsReinforcement.Application.ColumnsReinforcementCommandStarter.StartComm
and(UIApplication uiApplication)
в mprColumnsReinforcement.Application.ColumnsReinforcementCommand.Execute(External
CommandData commandData, String& message, ElementSet elements)"

При нажатии на армирование стен появляется окно, жму выбрать, выбираю стену, нажимаю "анализировать" и появляется ошибка: "Не удалось загрузить тип "ModPlus_Revit.Utils.RebarUtils" из сборки "ModPlus_Revit_2022, Version=6.5.0.0, Culture=neutral, PublicKeyToken=null"."
"Источник mprWallsReinforcement_2022. Трассировка стека: " в mprWallsReinforcement.Services.RebarTypeService.get_CachedRebarBarTypeNominalMmD
iameters()
в mprWallsReinforcement.Models.RebarBarTypeWrapper.FillDiametersByTypes()
в mprWallsReinforcement.Models.RebarBarTypeWrapper.SetRebarBarTypeNames(IEnumerabl
e`1 names)
в mprWallsReinforcement.Models.ReinforcementAdvancedData.WallReinforcementData.Cre
ateRebarBarTypeWrappers()
в mprWallsReinforcement.Models.ReinforcementAdvancedData.WallReinforcementData..ct
or()
в mprWallsReinforcement.Models.ReinforcementAdvancedData.WallReinforcementData..ct
or(WallReinforcementDefaultData defaultData)
в mprWallsReinforcement.Models.AdvancedWall.InitializationAdvancedWall()
в mprWallsReinforcement.ViewModels.MainViewModel.<Analysis>d__77.MoveNext()"

При нажатии на армирование плит появляется окно, жму выбрать, выбираю плиту, нажимаю "анализировать" и появляется ошибка: "Не удалось инициализировать плиту: Не удалось загрузить тип "ModPlus_Revit.Utils.RebarUtils" из сборки "ModPlus_Revit_2022, Version=6.5.0.0, Culture=neutral, PublicKeyToken=null".: 427739".
"Источник mprSlabsReinforcement_2022. Трассировка стека: " в mprSlabsReinforcement.Services.RebarTypeService.get_CachedRebarBarTypeNominalMmD
iameters()
в mprSlabsReinforcement.Models.RebarBarTypeWrapper.FillDiametersByTypes()
в mprSlabsReinforcement.Models.RebarBarTypeWrapper.SetRebarBarTypeNames(IEnumerabl
e`1 names)
в mprSlabsReinforcement.Models.ReinforcementAdvancedData.FloorOpeningReinforcement
Data.CreateRebarBarTypeWrappers()
в mprSlabsReinforcement.Models.ReinforcementAdvancedData.FloorOpeningReinforcement
Data..ctor()
в mprSlabsReinforcement.Models.ReinforcementAdvancedData.FloorOpeningReinforcement
Data..ctor(FloorOpening floorOpening, FloorOpeningReinforcementDefaultData defaultData)
в mprSlabsReinforcement.Models.FloorOpening..ctor(AdvancedFloor advancedFloor, FloorOpeningGeometry floorOpeningGeometry)
в mprSlabsReinforcement.Models.AdvancedFloor.<GetOpenings>d__50.MoveNext()
в System.Linq.Buffer`1..ctor(IEnumerable`1 source)
в System.Linq.OrderedEnumerable`1.<GetEnumerator>d__1.MoveNext()
в System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
в System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
в mprSlabsReinforcement.Models.AdvancedFloor.TryToInitialize(String& errorMessage)"

Что не так?

Сообщение отредактировал Bokko - 10.05.2021 - 22:18
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
arturice
сообщение 14.05.2021 - 22:18
Сообщение #68


Новичок
Иконка группы

Группа: Пользователи
Пользователь №: 91931
Сообщений: 15
Регистрация: 25.06.2008
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 3 раз(а)



@на 07.05.2021 последняя версия конфиругатора 11.8. Нечего патчить новее@ Так и не заработало, вылетает с ошибками как в предыдущем посте, не знаю что делать(((
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
arturice
сообщение 15.05.2021 - 10:19
Сообщение #69


Новичок
Иконка группы

Группа: Пользователи
Пользователь №: 91931
Сообщений: 15
Регистрация: 25.06.2008
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 3 раз(а)



Всем привет. У кого на версии 11.8 вылетает ошибка на ревите 2021 Could not load type 'ModPlus_Revit.Utils.RebarUtils' from assembly 'ModPlus_Revit_2021, Version=6.5.0.0, Culture=neutral, PublicKeyToken=null'. как это побороть, модуль с плитой и колоннами тоже не работает((( кто сталкивался и может какое решение нашли? на 11.7 если снести и поставить через конфигуратор тоже ничего не работает из стен плит и колонн((( на одном компьютере помогло только восстановление из корзины на 2020 ревите, на ноутбуке поставил 2021 ревит из-за смежников которые ставят все самое последнее и беда.... не работает(((
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Bokko
сообщение 20.05.2021 - 17:56
Сообщение #70


Прохожий
Иконка группы

Группа: Пользователи
Пользователь №: 79610
Сообщений: 35
Регистрация: 22.11.2007
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 23 раз(а)



Заработало. Скачал с сайта разработчика, установил. Отсюда взял ModPlusAPI.*, заменил в ...AppData\Roaming\ModPlus\Extensions
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
arturice
сообщение 20.05.2021 - 18:17
Сообщение #71


Новичок
Иконка группы

Группа: Пользователи
Пользователь №: 91931
Сообщений: 15
Регистрация: 25.06.2008
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 3 раз(а)



Цитата(Bokko @ 20.05.2021 - 17:56) *
Заработало. Скачал с сайта разработчика, установил. Отсюда взял ModPlusAPI.*, заменил в ...AppData\Roaming\ModPlus\Extensions

можне более подробно описать, что скачивалось и какой именно файл заменялся, так как есть веб установщик и есть конфигуратор, также там 3 файла с API* ?
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Bokko
сообщение 20.05.2021 - 18:30
Сообщение #72


Прохожий
Иконка группы

Группа: Пользователи
Пользователь №: 79610
Сообщений: 35
Регистрация: 22.11.2007
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 23 раз(а)



Установил официальную. Проверил, армирование работает, но с ограничениями лицензии. Заменил все 3 файла API на лавтимовские и на всякий случай удалил все файлы в modplus, вместо них вставил лавтимовские. Не проверял, но скорее всего достаточно заменить файлы api.

Сообщение отредактировал Bokko - 20.05.2021 - 18:31
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
arturice
сообщение 22.05.2021 - 08:20
Сообщение #73


Новичок
Иконка группы

Группа: Пользователи
Пользователь №: 91931
Сообщений: 15
Регистрация: 25.06.2008
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 3 раз(а)



Цитата(Bokko @ 20.05.2021 - 18:30) *
Установил официальную. Проверил, армирование работает, но с ограничениями лицензии. Заменил все 3 файла API на лавтимовские и на всякий случай удалил все файлы в modplus, вместо них вставил лавтимовские. Не проверял, но скорее всего достаточно заменить файлы api.


@достаточно заменить файлы api@ - нужно заменять и эти файлы и то что в корне, обязательно удалить автообновление из папки, если не заменить файлы в корне - будет ругаться на левые файлы API. похоже дело в файлах в папке Extensions и достаточно заменить их на файлы из папки с файлами конфигуратора с офсайта, кроме файлов API.
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Nfors85
сообщение 6.06.2021 - 21:52
Сообщение #74


Из местных
Иконка группы

Группа: Пользователи
Пользователь №: 124536
Сообщений: 52
Регистрация: 1.10.2009
Загружено: байт
Скачано: байт
Коэффициент: ---
Спасибо сказали: 13 раз(а)



Конфигуратор обновился до версии 11.8.2.0. Если есть возможность обновите пожалуйста.
Перейти в начало страницы
Вставить ник
+Цитировать сообщение
Slinger
сообщение 7.06.2021 - 15:27
Сообщение #75


Флудер
Иконка группы

Группа: Модераторы
Пользователь №: 143610
Сообщений: 758
Регистрация: 7.03.2011
Загружено: 0 байт
Скачано: 0 байт
Коэффициент: ---
Спасибо сказали: 1796 раз(а)



Обновлено до 11.8.2.0
Перейти в начало страницы
Вставить ник
+Цитировать сообщение

4 страниц V  « < 2 3 4
Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 20.06.2021 - 20:15